It is important to keep your web browser up to date, so that you will be able to utilise all of the features of TourConnect.


TourConnect is compatible with the following browsers:

 

·         Microsoft Edge

·         Internet Explorer (version 11)

·         Firefox (versions 42, 43 and above)

·         Google Chrome (versions 46, 47 and above)

·         Safari (versions 8, 9 and above)